Author Topic: Common configuration issue with SSL enabled servers and the solution  (Read 5374 times)

yDecode

  • Administrator
  • Jr. Member
  • *****
  • Posts: 61
    • View Profile
One of the common problems beginners get with SSL enabled servers and yDecode is that they apparently configure everything correctly (no problems in "test config") but the system doesn't work.

IMPORTANT NOTE: Do not use SSL if your server does not require it - it will not be any better if you enable it - in fact - it won't work at all!

If this may be the case for you as well please make sure that the following configuration is met:

yDecode

1. Set Remote Server to your server name - e.g. news.yourhost.com
2. Set Remote Port to 563
3. Check the SSL box to enable SSL connection
4. Set Local Port to 119

Outlook Express, Windows Mail or other newsreader

1. Set server name to localhost (or 127.0.0.1)
2. Set port to 119 (same as local port above)
3. UNCHECK SSL option in Outlook Express or other newsreader

This will result in unencrypted (non-SSL) connection on your machine but encrypted connection to the actual server.

The key here is to uncheck the SSL option in your newsreader because yDecode cannot (and does not need to) accept encrypted connections and they are also not needed locally (SSL connections are slower than non-SSL ones). But it can use SSL with remote servers.

If you experience an issue with SSL enabled server try the above configuration - it should work.
« Last Edit: May 24, 2009, 01:51:02 AM by Zvonko »